Jump to content

Cannot deploy CS:GO but other games work


Recommended Posts



I have a fresh standalone install and I can deploy HalfLife and CSS without incident but I am unable to deploy a CS:GO server. It always fails with the same error:


CS:GO 12 slots (Master)
8/22/2016 3:11:20 PM	Creating a CS:GO server for Admin on server Master
8/22/2016 3:11:20 PM	Searching for an ip that has the required ports
8/22/2016 3:11:20 PM	Selected ip x and port 27020
8/22/2016 3:11:20 PM	Building the command line
8/22/2016 3:11:20 PM	Searching for a file source
8/22/2016 3:11:20 PM	Copying directory csgo-linux
8/22/2016 3:16:08 PM	Moving temporary directory to /home/tcagame/admin/3/
8/22/2016 3:16:09 PM	Writing the configuration files
8/22/2016 3:16:09 PM	Writing the config file /home/tcagame/admin/3/csgo/cfg/server.cfg
8/22/2016 3:16:09 PM	Configuring the game service
8/22/2016 3:16:09 PM	An error occurred. Time to clean up. (CreateGameServer)
8/22/2016 3:16:09 PM	Deleting the service with id 3 from the database
8/22/2016 3:16:33 PM	The file /home/tcagame/admin/3/srcds_run does not exist
8/22/2016 3:16:33 PM	System.IO.FileNotFoundException: The file /home/tcagame/admin/3/srcds_run does not exist File name: '/home/tcagame/admin/3/srcds_run' at TCAdmin.GameHosting.Automation.AutomationProcesses.***1346; () [0x00000] in <filename unknown>:0 at TCAdmin.GameHosting.Automation.AutomationProcesses.Start () [0x00000] in <filename unknown>:0 at TCAdmin.TaskScheduler.ModuleApi.StepBase.Start (System.Object arguments) [0x00000] in <filename unknown>:0


The '3' directory doesn't exist so it seems to have an issue with moving over the installation. There's hundreds of gigabytes of available space and again, deploying HalfLife and CSS works without incident (half life is under 1 and CSS is under 2). Any advice would be appreciated. Thanks!





Link to comment
Share on other sites

Okay so I solved my own problem TCAdmin failed to download the complete game files from Steam. I manually downloaded CS:Go with SteamCMD and it took about 14 restarts before it finally got to 100%. I then copied the contents across to the csgo-linux directory under tcafiles and was then able to deploy a CS:Go server from TCAdmin!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use