Jump to content

How to enabled fast download MTA Server using nginx with tcadmin


SRmasazuka
 Share

Recommended Posts

Olá, todos como vão?

Depois de muito esforço e noite em claro consegui chegar até aqui. Porem algo que me tira o sono a uns 3 dias é o acelerador de download. Simplesmente não consigo entender.
Tudo está configurado no meu tcadmin, mas não consigo configurar o acelerador de download no TCAdmin usando um servidor nginx.

Se alguém poder me ajudar, ou tive rum tutorial mais detalhado de como posso fazer isso. Ficarei muito grato.
Peço desculpas em vir logo pedir ajuda, mas a licença do TCA é meio salgado para um Brasileiro, então não posso perder tempo. Tanks ?
 -----
Hello guys.

I'm having trouble enabling the fast download function for mta server on windows using the TCAdmin panel. It just doesn't work for me.
I read it several times or tcadmin wiki. Even though I managed to get the mods to sync, I can't get mtaserver.config to automatically add a download URL.
Please, if anyone has a more detailed tutorial on windows I would be very grateful.

Link to comment
Share on other sites

1 hour ago, JMTS said:

Oi amigo, qual é o seu erro? O Nginx inicia corretamente?

Primeiramente obrigado por responder.

Aparentemente sim. Inicio ele e logo consigo acessar pelo http://127.0.0.1 também tentei fora da máquina pelo ip e funciona. Porem não consigo configurar meu tcadmin para acelerar o download. Infelizmente não consegui pelo wiki. Mexendo e reconfigurando várias e várias vezes consegui até fazer com que as pastas fiquem sincronizadas(Não sei se fiz certo). Mas mesmo assim no mtaserver.config não fica com a url de download rápido. ?

Link to comment
Share on other sites

16 minutes ago, SRmasazuka said:

Primeiramente obrigado por responder.

Aparentemente sim. Inicio ele e logo consigo acessar pelo http://127.0.0.1 também tentei fora da máquina pelo ip e funciona. Porem não consigo configurar meu tcadmin para acelerar o download. Infelizmente não consegui pelo wiki. Mexendo e reconfigurando várias e várias vezes consegui até fazer com que as pastas fiquem sincronizadas(Não sei se fiz certo). Mas mesmo assim no mtaserver.config não fica com a url de download rápido. ?

Beleza, vamos lá.
Como você configurou o Nginx?
Pode me enviar aqui como está atualmente seu nginx.conf?

Link to comment
Share on other sites

3 minutes ago, JMTS said:

Beleza, vamos lá.
Como você configurou o Nginx?
Pode me enviar aqui como está atualmente seu nginx.conf?

Posso sim, claro.

Utilizo o nginx no windows. Fiz algumas alterações no nginx.config de acordo com o tutorial do mta. https://wiki.multitheftauto.com/wiki/Installing_and_Configuring_Nginx_as_an_External_Web_Server
Porem segui o tutorial do tcadmin. Talvez isso que esteja me confundindo.

Segue por favor as configurações de C:\nginx\conf\nginx.conf

worker_rlimit_nofile 5000;
worker_processes  1;

events {
    worker_connections  5000;
}


http {
    include       mime.types;
    default_type  application/octet-stream;

    sendfile        on;
    keepalive_timeout  65;
	gzip  on;
	gzip_types *;


    server {
        listen       80;
        server_name  localhost;

        location / {
            root   html;
            index  index.html index.htm;
        }

        error_page   500 502 503 504  /50x.html;
        location = /50x.html {
            root   html;
        }

    }

}

 

Link to comment
Share on other sites

6 minutes ago, SRmasazuka said:

Posso sim, claro.

Utilizo o nginx no windows. Fiz algumas alterações no nginx.config de acordo com o tutorial do mta. https://wiki.multitheftauto.com/wiki/Installing_and_Configuring_Nginx_as_an_External_Web_Server
Porem segui o tutorial do tcadmin. Talvez isso que esteja me confundindo.

Segue por favor as configurações de C:\nginx\conf\nginx.conf


worker_rlimit_nofile 5000;
worker_processes  1;

events {
    worker_connections  5000;
}


http {
    include       mime.types;
    default_type  application/octet-stream;

    sendfile        on;
    keepalive_timeout  65;
	gzip  on;
	gzip_types *;


    server {
        listen       80;
        server_name  localhost;

        location / {
            root   html;
            index  index.html index.htm;
        }

        error_page   500 502 503 504  /50x.html;
        location = /50x.html {
            root   html;
        }

    }

}

 

Em server, substitui por esse:

server {
    listen 20080;
    root /(localização da pasta de fastdownloads do TCAdmin);
    server_name localhost;
    access_log off;
    autoindex off;
}
Link to comment
Share on other sites

7 minutes ago, JMTS said:

Em server, substitui por esse:


server {
    listen 20080;
    root /(localização da pasta de fastdownloads do TCAdmin);
    server_name localhost;
    access_log off;
    autoindex off;
}

Obrigado amigo, sigo agora normalmente o wiki do tcadmin ou me recomenda fazer alguma outra configuração no tcadmin?

Link to comment
Share on other sites

Estou fazendo errado, mas não consigo achar meu erro. Apenas essa parte de fast download ainda me atormenta pra continuar meu projeto. Caso possa me ajudar, tirei algumas print de todas as minhas configurações. Desde já, muito obrigado. ?

Arquivo: mtaserver.config

https://i.imgur.com/ZNobRsx.png

Arquivo: C:\nginx\html\fastdownload

https://i.imgur.com/F7rR82N.png

Configuração Fast Download em servidores do TCAdmin:

https://i.imgur.com/qNYOJKx.png

Configuração Fast Download no jogo.

https://i.imgur.com/HXR0W4a.png

Configuração nginx:

https://i.imgur.com/hg0XldW.png

Desculpe, não consegui inserir imagem direto no tópico. 

Link to comment
Share on other sites

1 hour ago, JMTS said:

Em Files To Sync, coloque * (para sincronizar todos)
Em Fast Download URL (Configurações da máquina, não do jogo), falta colocar :20080 depois do IP do servidor, e na verdade é só assim: http://51.161.71.237:20080/

Fiz as modificações indicadas. As sincronizações continuam mas ao criar um novo serviço de jogo o arquivo de configuração mtaserver.config sempre criado sem nenhum link de fast download <httpdownloadurl>$[FastDownloadUrl]</httpdownloadurl>
Fiz um teste dentro da máquina http://51.161.71.237:20080/51.161.71.237_22073/ e me apresenta um erro 403 Forbidden.
Já no meu computador quando tento o acesso sou redirecionado para http://51.161.71.237:22073/resourcebrowser/ e pede login e senha. 
Por gentileza, saberia me dizer se tal erro tem haver com o <httpdownloadurl> sempre ficar em branco?

Link to comment
Share on other sites

Coloca "user tcadmin" no topo do nginx.conf, se não resolver apenas isso, coloque a pasta de fastdownloads no diretório do TCAdmin mas mantenha a configuração "user tcadmin".
Na verdade, você não deveria ser redirecionado para resoursebrowser. O link de  download dos servidores deve dar em http-client-files, dentro da pasta resources-cache do MTA.

Você já configurou um download rápido antes na vida? Independentemente de TCAdmin?

Edited by JMTS
Link to comment
Share on other sites

10 minutes ago, JMTS said:

Coloca "user tcadmin" no topo do nginx.conf, se não resolver apenas isso, coloque a pasta de fastdownloads no diretório do TCAdmin mas mantenha a configuração "user tcadmin".
Na verdade, você não deveria ser redirecionado para resoursebrowser. O link de  download dos servidores deve dar em http-client-files, dentro da pasta resources-cache do MTA.

Você já configurou um download rápido antes na vida? Independentemente de TCAdmin?

Ainda nada.

Infelizmente não. Não consegui encontrar um tutorial correto desse modo de aceleração do mta:sa com tcadmin, nem mesmo quem cobre para esse tipo de serviço. Então tenho que fazê-lo sozinho. Não imaginava que teria tantos problemas apenas com "fast download" todo o resto consegui instalar e fazer sem problemas algum. 

 

Link to comment
Share on other sites

Just now, SRmasazuka said:

Ainda nada.

Infelizmente não. Não consegui encontrar um tutorial correto desse modo de aceleração do mta:sa com tcadmin, nem mesmo quem cobre para esse tipo de serviço. Então tenho que fazê-lo sozinho. Não imaginava que teria tantos problemas apenas com "fast download" todo o resto consegui instalar e fazer sem problemas algum. 

 

Pois então, primeiramente, tente compactar um servidor apenas. É só seguir o Wiki do MTA.
Uma dica, em servidores Windows, deixe a pasta do nginx na área de trabalho.
Em root, aponte para a http-client-files do servidor de testes.

Quando você conseguir configurar o primeiro servidor, você tenta fazer agora com o TCAdmin...
Se você não conseguir configurar nem para o servidor de testes, me chama na DM.

Link to comment
Share on other sites

Just now, JMTS said:

Pois então, primeiramente, tente compactar um servidor apenas. É só seguir o Wiki do MTA.
Uma dica, em servidores Windows, deixe a pasta do nginx na área de trabalho.
Em root, aponte para a http-client-files do servidor de testes.

Quando você conseguir configurar o primeiro servidor, você tenta fazer agora com o TCAdmin...
Se você não conseguir configurar nem para o servidor de testes, me chama na DM.

Certo. tentarei fazê-lo agora. Muito obrigado pela ajuda amigo. Vou tentar agora.

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Who's Online   0 Members, 0 Anonymous, 3 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use