Jump to content

FastDL + Nginx


Carlos Dorelli
 Share

Recommended Posts

I think nginx will throw a 404 if there's no index file by default (since Directory Index is disabled). You're still able to access the files directly by using the complete link to the file.

You could enable Directory Index by adding this to your location block:

location /fastdldir/ {
    autoindex on;
}

 

Link to comment
Share on other sites

19 hours ago, Dennis said:

I think nginx will throw a 404 if there's no index file by default (since Directory Index is disabled). You're still able to access the files directly by using the complete link to the file.

You could enable Directory Index by adding this to your location block:


location /fastdldir/ {
    autoindex on;
}

 

Thanks for the reply. I did it but still getting error 404 on nginx.

#Remover erro 404 no link do FastDL
location /home/tcadmin/tcafiles/fastdownloads/ {
	autoindex on;
}

image.thumb.png.4f25ca36d09d6acad4d189326b849cf0.png

Link to comment
Share on other sites

1 hour ago, CarlosDorelli said:

Thanks for the reply. I did it but still getting error 404 on nginx.


#Remover erro 404 no link do FastDL
location /home/tcadmin/tcafiles/fastdownloads/ {
	autoindex on;
}

image.thumb.png.4f25ca36d09d6acad4d189326b849cf0.png

Are you editing the default.conf or did you make a new one? make sure it is pointing to the correct document root. nginx default is /var/www/html

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use