Jump to content

Permission 'Issue'?


forbiddenwon
 Share

Recommended Posts

ok, on a freshly wiped Win 10 machine, followed the TCA install instructions... only game server set up atm is 7DTD.... left everything as default.... when i start the server i get
 

ERR [Steamworks.NET] GameServer.LogOn timed out

the command line config reads:
 

runas /user:TCAGame cmd.exe
Password: (password)
cd /d C:\TCAFiles\Users\admin\1\
7DaysToDieServer.exe -quit -batchmode -nographics -configfile=serverconfig.xml -dedicated -logfile C:\TCAFiles\Users\admin\1\7DaysToDieServer_Data\output_log.txt

i stopped the server via the TCA and went to the machine, opened up CMD and attempted the commands above, same result
i then opened up CMD with 'run as administrator' and just ran
 

cd /d C:\TCAFiles\Users\admin\1\
7DaysToDieServer.exe -quit -batchmode -nographics -configfile=serverconfig.xml -dedicated -logfile C:\TCAFiles\Users\admin\1\7DaysToDieServer_Data\output_log.txt

it opens and connects fine, users can log in and use the server....

not sure where to look at this point? signs point to permission issue, as running as full admin works...

Link to comment
Share on other sites

ran the per correction, and 'update the run as user' same results... thing that stands out, is when i run the commands as the tcagame user, there is always 1 less listening port active then when i run the command as admin....

when running with the tcagame user, the server loads, and you can even see in in game server list, but you can not connect.... below are images of the netstat results when each attempt is made, nothing changed other then the user running the process....

admin.PNG

tcagame.PNG

Link to comment
Share on other sites

ok, so more specifically, the query port is not listening when i run it any other way via TCA, even changing the run as user to local account... but if i start the server in place via CMD as either the local account nor CMD run as admin, it starts and the query port is active (see images above)

i attempted an ark server as well, same results, the query port does not 'listen' via TCA starting the games...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use