Jump to content

Error Creating ARK Server - Other servers work fine


Recommended Posts

Hi, 

When I try to create an ARK Server I get this issue. It installs as far as creating the folder and then hangs with this error.

 

I have reinstalled tcadmin and the database is a fresh install now sick of pulling my hair out. 

My next option is to reinstall mysql and see if that fixes it. 

Any Ideas before I do that running Windows Server 12 R2 on a Remote Dedi which has always worked perfectly for the last few years. 

 

Thanks All

10/21/2022 9:00:44 PM Executime to clean up. (CreateGameServer)ng event scripts for AfterCreate (service id 5)
10/21/2022 9:00:44 PM An error occurred. Ti
10/21/2022 9:00:44 PM Deleting the service with id 5 from the database
10/21/2022 9:01:01 PM Method not found: 'System.Management.Automation.PSDataCollection`1<System.Management.Automation.InformationRecord> System.Management.Automation.PSDataStreams.get_Information()'.
10/21/2022 9:01:01 PM System.MissingMethodException: Method not found: 'System.Management.Automation.PSDataCollection`1<System.Management.Automation.InformationRecord> System.Management.Automation.PSDataStreams.get_Information()'. at TCAdmin.SDK.Scripting.Engines.PowerShellEngine.Execute(Credentials credentials) at TCAdmin.SDK.Scripting.ScriptEngineManager.Execute() at TCAdmin.GameHosting.SDK.Objects.GameScript.ExecuteEventScripts(ScriptEngineManager scriptEngineManager, ServiceEvent eventScript, ObjectList scripts) at TCAdmin.GameHosting.Automation.AutomationProcesses.e() at TCAdmin.GameHosting.Automation.AutomationProcesses.Start() at TCAdmin.TaskScheduler.ModuleApi.StepBase.Start(Object arguments)
Link to comment
Share on other sites

Fixed it at last after reinstalling everything just in case and still getting the same error it was a powershell update error Ark needed powershell 5 on Windows Server 2012 R2.

The update was being blocked by a missing folder in my windows directory.

(Folder was "AUInstallAgent" )

Just creating the folder allowed me to update powershell then Ark installed fine. 

Hope this helps someone 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Who's Online   0 Members, 0 Anonymous, 5 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use