Jump to content

Does not connect to billingapi


Recommended Posts

I cant get ClientExec to work with TCADMIN.


It locks like ClientExec does not connect to tcadmin (billingapi.aspx)


I cant see that ClientExec is trying to connect.


Billing API Settings in tcadmin i have allowed the ip from the ClentExec.

I tryed another ip to see in the logfile to billingapi and i dont get "Access denied"


I am sure that i have the billingApi url right.


Is it any webserver config i need to do on apache where the ClientExec are installed?



Link to comment
Share on other sites

This is the Error mail i get:




Alert, the tcadmin plugin hasn't executed fully, and resulted in a

FAILED action. Please review this email as it contains information

about what has happen

Client Email: me@me.no

Client name: maal dsfsfk

Package ID: 22

Package Name: test test test

Settings sent to Tcadmin, results are as follow, [NAME] => VALUE, the

name is the name of the action, the value is what was set.




[function] => AddPendingSetup

[game_package_id] => 22

[voice_package_id] => 22

[client_id] => 126

[user_email] => me@me.no

[user_fname] => maal

[user_lname] => dsfsfk

[user_address1] => fsdmdfms

[user_address2] =>

[user_city] => fmmfj

[user_state] => FL

[user_zip] => 1223

[user_country] => NO

[user_phone1] => 32324234

[user_phone2] =>

[user_name] => Jalla

[user_password] => JallaBalla

[game_id] => 10

[game_slots] => 20

[game_private] => 1

[game_additional_slots] =>

[game_branded] =>

[game_additional_arguments] =>

[switch_at_once] => 0

[voice_id] =>

[voice_slots] =>

[voice_private] =>

[voice_additional_slots] =>

[skip_page] => 1

[game_datacenter] => TC0633808447606

[game_hostname] =>

[game_rcon_password] =>

[game_private_password] =>

[voice_datacenter] =>

[voice_hostname] =>

[voice_rcon_password] =>

[voice_private_password] =>





Tcadmin has responded with the following:







----- Things to check for the server properties -----

Ensure the server settings are set correct, In Clientexec goto

Admin->Servers select the Tcadmin server, check the following:

Billing API url, This should be the url to your billingapi.aspx. Such

as http://panel.yoursite.com/billingapi.aspx


Admin username, This should be the administrators username, the one

you login with on tcadmin.


Admin password, This is the password you use to login with the above

admin username, on tcadmin.


Client Username Custom Field, Should be the exact name that you had

used for the clients username field, See: Admin->Customfields, Select

the package custom fields. The field name should match.


Client Password Custom Field, Same as for the username custom field.


Location Custom Field, The name should also match, Using this you

should have the Location set to a drop down menu, For the options you

should have the Name of the location, and the tcadmin datacenters id

in (), so it looks like "West (TC12382189398120)"


If you wish to use ( or ) in the options, escape it with a \ Example:

La \(Level3!\)(TC1283912893219). To specify more than one location,

sperate each one by a comma. An example would be: North

(TC239210931209),East (TC92193912090), North (TC892138129321)


The Datacenters id can be located by logging into your game panel,

Going to System Settings->Datacenters, There you will see the

datacenters ID.


---- Check the package settings ----

Make sure the game_slots value isn't blank (You can see it above.)


Make sure the game_id value is set (Look above.)


Make sure the game_datacenter is set.


If game_level is being used, ensure you have a datacenter with the

same game level.



In most cases, there will be an error message above. (Which is the



Here is a few simple error messages and how to fix them:


Access denied: Check the username/password you had entered in for the

Admin username/password.


Blank response: This is normally caused by the IP of the webserver not

being allowed to use the billing api. To add this, in Tcadmin goto

System Settings -> Plugins -> under TC_GSAUTO Click configure. Scroll

down until you see Billing API Settings

Make sure the Billing api is checked.

Under Allowed IPs, enter your webservers ip Note: Enter one ip per



Link to comment
Share on other sites

  • 2 months later...


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use