Jump to content

How to change my server IPs?


Terran

Recommended Posts

Hi there, I am looking into TCAdmin for a small personal gaming community. I downloaded your free trial but I am having trouble with it. (My fault)

 

When I create the game servers, the IP are my internal IP such as 192.168.0.108:27015 and 27106.

 

I know that isn't right, and it should display an external IP that others can connect to. I cannot even connect to it on my LAN.

 

Does anyone know what I'm doing wrong? I am on Windows Server 2008 and haven't messed with anything but creating a static IP and port forwarding on my router.

 

Thanks

Link to comment
Share on other sites

Thank you very much for the quick response. You guided me in the right direction however I am unable to create a server using my external IP. I think I have all the ports forwarded correctly however the master console gets stuck at, "finding available open ports" or something like that.

 

Do you have any suggestion? Once again, I appreciate your prompt help!

Link to comment
Share on other sites

Try using your internal IP (192.168.x.x) on your master and manually change the IP of the game server to your external. (change it in the command line)

In TCAdmin the internal IP will be used on the game server, but the command line saying something else (external IP)

 

You will not be able to get it automated, but you can at least test the functionality.

Link to comment
Share on other sites

So I tried it and no luck. I changed the command line to reflect the external IP but the connection is still not going through.

 

I opened up these ports on my router:

 

start end protocol (TCP/UDP)

1200 1200 both

27000 27015 both

27020 27039 both

 

I created a static IP on the master server.

 

I'm not sure if there is anything else I need to do. Do I need to add roles to my server to let it communicate?

 

Sorry, I'm very new to this.

 

Thanks

Link to comment
Share on other sites

when u go to system settings > servers in the dropdown box try "import Ip's" and see if all the IP's are imported automatically. If they arent then there must be something wrong in your setup (server side not tcadmin).

 

 

Else try to put your local IP in "Hardware Firewall IP:" in your TCA server properties.

 

Note that in order for TCA to work you need port 8888 forwarded too.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 16 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use