Jump to content

BF2 not running through tcadmin


Broseph

Recommended Posts

Using this config: http://208.77.144.55/downloads/TCAdminConfigs/Battlefield%202%20Non%20Ranked.rar

 

Simply does not run and according to tcadmin it is crash cycling. However, if I start the server manually it runs just fine.

 

I've also installed BF2CC and changed the startup exe accordingly but I run into a similar error. BF2CCD.exe loads up just fine when started through tcadmin but I get the following error in bf2cc logs:

 

BF2 process has stopped on Map: Unable to Query Map Name

 

And the actual game server never starts. Again, if I start the bf2cc daemon manually everything starts up perfectly.

 

Any idea what the cause could be? Thanks in advance!

Link to comment
Share on other sites

I've gone with a fresh install without BF2CC, dedicated server v1.4.1 downloaded straight from the EA website and it launches just fine if I click it manually. If I try to run it through TCAdmin it just crash cycles over and over again. I've only got one line in maplist.con:

 

mapList.append kubra_dam gpm_cq 16

 

I've double checked paths and everything and yet it refuses to work. Any help would be greatly appreciated.

Link to comment
Share on other sites

I've found my problem by doing a deeper search of the forums and it boils down to my operating system which I neglected to mention. In Windows Server 2008 R2 a small adjustment to the game service is required in order to get it to work. You have to view all services and find the particular one you're interested in and then click properties --> log on. Then you have to provide a specific account for the service to run under.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use