Jump to content

CentOS 7 Tcadmin


Recommended Posts

So I recently switched from CentOS 6 to 7 due to the steamcmd glib 2.5 issues I could not get resolved. I had to force the tcadmin package to install and everything started up except for some VB microsoft errors.


I assume this has to do with mono, I've installed the repo for mono and mono-complete and everything and TCadmin still won't load correctly or show that port 8880 is open using nmap.


Not sure what is going on. Anyone have experience with CentOS 7 can chime in?

Link to comment
Share on other sites

When i was installing tcadmin yesterday i had an issue installing the mono from the TCAdmin recommended option. to fix it i first added this then just followed the instructions on the tcadmin installation guide and it worked.


" Regardless of your distribution, you will need the Mono Project GPG signing key, which package managers require.


Debian, Ubuntu, and derivatives#

Add the Mono Project GPG signing key (if you don?t use sudo, be sure to switch to root):


apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

Next, add the package repository (if you don?t use sudo, be sure to switch to root):


echo "deb http://download.mono-project.com/repo/debian wheezy main" | tee /etc/apt/sources.list.d/mono-xamarin.list "



just followed the instructions here:



i know your trying to use CentOS but maybe similar issue.



Link to comment
Share on other sites

Yeah I finally got mono installed and rebuilt into rpm format and installed correctly and updated and made sym links but it still persisted in causing issues and TCadmin would not open.


So the quick answer is: TCadmin does not work on CentOS 7 right now, no matter what you try it will not work as of yet.



and Steam has Glibc issues (Requires 2.15+ but you only have 2.12 installed) on CentOS 6 that I did not want to deal with. Ubuntu 12.04 is working but I still have an issue. I'll make a new thread for that though.

Link to comment
Share on other sites

  • 4 weeks later...



When I started hosting, I did the same thing you did. I started off with CentOS 6, and then moved to 7. I ran into the same problems you were, and finally decided to go with a new platform. I'm running Ubuntu 14.04 on my Master and Remote 1 servers, and haven't given me an issue yet.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 4 Guests (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use