Jump to content

Can?t run hlds through tcadmin panel


Recommended Posts

Hi, I?m having an issue running hlds dedicated server, when I try to run through tcadmin panel server won?t start.

This is the error I have:

[s_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

Segmentation fault


What I?ve tried to diagnose the issue:


- Went to Game Services-Service settings-Command line

- copy the the command line parameters and tried to run using putty but also didnt work


Tried to do the same thing but instead of running as "tcagame" user I?ve tried as root user, when I run the same command as root user Server starts without any issue.


This is my first time using Tcadmin panel, any idea how can I fix this issue?

Server works when I run as root but it doesnt work when I run as tcagame user.


Any help is greattly apprecciated.

Thanks in advance.

Edited by brlight
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use