Jump to content

Ark: Survival Ascended


Recommended Posts

Ark: Survival Ascended

This is the first Ark: Survival Asceneded config with more updates to come.


  1. Download the config
  2. Go to TCAdmin > System > Settings > Game & Voice Hosting > Game & Other Voice Servers > Import
  3. Save the config as a new config or chose "Overwrite existing config" if you which to overwrite your current config.
  4. Leave all other settings


  • Added Custom & Default Variables and part Configuration Editor
  • RCON thru mcron (ArkCon also works)
  • Curseforge now added - thanks TCADMIN team
  • Query added - thanks Gardiny (player part now working, again thanks Gardiny)
  • Battlemetrics connection
  • Backup scripts and scheduled tasks

Known Issues...

No query checking. Still working on getting A2s protocol to work.


To Do...

Game.ini config editor (unless others work on it)


Edited by jungleNZ
added battlemetrics button for rcon details
Link to comment
Share on other sites

59 minutes ago, crunkinshoe said:

Are you saying to use https://github.com/Tiiffi/mcrcon for RCON? If so the correct exe is mcrcon.exe not mcron.

If you use that one then yes it is mcrcon.exe. The one I used was from sourceforge, even thou it says mcrcon the exe is labelled mcron.

Whatevever one you use you need to put the exe into c:\program files\tcadmin2\monitor\tools.

Link to comment
Share on other sites

54 minutes ago, crunkinshoe said:

Currently no way to bind an IP I'm guessing? Multihome doesn't seem to be working.

This is from their WIKI:



Enables multihoming. MULTIHOME=<IP_ADDRESS> must be specified as well in GameUserSettings.ini under [SessionSettings] or in the command line.

Edited by jungleNZ
Link to comment
Share on other sites

The querying is basic and might not pick everything up.

I have updated config to allow connection to battlemetrics rcon (you need to sign up with them to use it - free). This provides all the info needed.


Link to comment
Share on other sites

Query playercount work well for me, but i dont using this config, maybe there isnt server logging in commandline

In my config i using this, and query work without problem 

"TheIsland_WP?Port=7960?QueryPort=27198?RCONEnabled=True?RCONPort=27203?listen" -server -log -servergamelog --WinLiveMaxPlayers=10

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Who's Online   0 Members, 0 Anonymous, 4 Guests (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use