Jump to content

FTP crapping out


adamscybot

Recommended Posts

When customers download from FTP, they get the following after a few MB has been downloaded:

 

451 Requested action aborted: local error in processing.

 

Tried various FTP clients, altering memory buffers of IIS etc. There is enough diskspace, everything seems fine.

 

Help!

Link to comment
Share on other sites

I *appear* to have fixed it, but it is erratic so I can't be certain. Time will tell.

 

What I did was to go to the device manager. properties of my (onboard) Realtek RTL8168/8111 network adaptor. Then went to the advanced tab, selected "Offload TCP_LargeSend" and changed it from enabled to disabled. Clicked ok.

 

BOOM! 800kb/s on 100mb 5 times in a row.

 

Google told me nothing about this error so I hope this solution helps people.

Link to comment
Share on other sites

Yeh the problem seems to be when there is a large amount of data packets, the NIC driver takes over to take load away from the CPU (neglible). The driver is bugged and corrupts packets.

 

You can also disable offloading of checksum checks.

 

This also fixed my slow loading TCADMIN. Awesome!

 

There is an update, not sure if it fixes this bug, im just keeping it as is for time being.

Link to comment
Share on other sites

Inbedded chip NICs are usually cheap and can cause problems I have found. Usually a good Intel card NIC is the way to go.

 

Actually realtek are resonably solid, this is just a one off - theyve been good for me in the past.

 

Although, obviously, a dedicated NIC has advantages.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 4 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use