Jump to content

Remotely enable Terminal Services..


Recommended Posts

This morning me and my college took a brand new server (and some switches) to the datacenter.


In our case, that means a 45 minute drive.




Arrived, put it into our rack and started installing windows 2003.


After that, the usual windows updates, ordered an extra tcadmin license and installed the tcadmin remote monitor.




Run a few tests and after everything looked ok we headed back to the office.




Nothing wierd so far eh? well...


when back at the office we realized we missed ONE item..






In case someone else makes the same stupid mistake, here's how to enable it remotely:




Start regedit and select : Connect Network Registry


(remote regedit)


If your servers are in AD (not recommended if you're just using it for games) just browse to the name, else type its IP in the searh form.




Once connected, browse in the remote registry to:


HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server




Select the key "fDenyTSConnection" and change the 1 to 0


Close regedit.




If you need to reboot (we didn't need to) then remotely reboot the server by:


shutdown -m \\ip.address.of.server -r




It beats a 45 minute (or longer.. i love traffic jams) drive back to the dc just to checkmark that option :smile:







Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 17 Guests (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use