Jump to content

Help with Manual game execution


HIS-MOTHER

Recommended Posts

I installed TCA and it is working flawlessly, no issues.

 

 

 

I run Novalogic affiliate servers but I have one client who runs a mod for Deltaforce Xtreme which requires me to do manual install of the retail build which TCA can not run based on game execution methods, and login for the server to the lobby.

 

 

 

This clients install existed prior to the TCA install.

 

 

 

The problem is when I manually start the game it terminates right away. I am assuming because it is started under Administrator credentials instead of System. It seems any Title once I have installed via TCA I can not host one of them manually. I did manage to host this same title on a box I have TCA installed on but did not install this game title.

 

 

 

Is there a way for me to get the game to start without installing it through TCA? :cry:

Link to comment
Share on other sites

I reinstalled the game thinking it got corrupt. I can not check the console because the game wont execute. I run the exe and it opens and closes instantly. It is not a DEP issues nor a game error as the event viewer does not even log it. It is acting like it doesn't have permission to run on the machine and I am logged in as administrator. This only happens after I have installed the same game under TCA. As I stated above I did install the same game from the same image onto another box with TCA on it and it ran fine. The only difference being is that this specific title was never installed via TCA on that box.

 

 

 

Does TCA consider the game EXE's protected for that whole gametype after the first install of it?

 

 

 

OS Server 2003 Standard 32 bit

 

Dual 2.8 Xeon EMT64

 

Raid 0 raptors

 

4GB ecc ram

Link to comment
Share on other sites

You should run the exe from a command prompt so you can see if there are any errors that can be seen.

 

 

 

Also, use a fresh copy of the game, don't try to run the exe within a tcadmin install. Copy the games to a seperate directory outside of TCAdmin, and then open a command prompt and attempt to run it from there.

 

 

Link to comment
Share on other sites

Nope same issue. Just closes with no errors. The game is outside the tca directory and was installed via cd image to its default install folder.

 

 

 

C:/Program Files/Novalogic/Deltaforcextreme

 

 

 

I tried unsuccesfully to run it under command prompt by either the command dfx.exe or dfx.exe -serveonly which is the commandline switch for a dedicated server in this title. or as close to one as you can get in Nova Retail builds. LOL

Link to comment
Share on other sites

No command line for the installs under TCadmin. The game fires up and calls CFG files.

 

 

 

Also the TCA installs are special affiliate/dedicateed versions , the one that will not fire up is a retail/over the counter build that was working fine. I am at a loss. The only thing I can see is that everything is running under system credentials and it wont allow it to run under administrator by manual execution.

 

 

 

I would move the guy to a Affiliate build but his mod wont run under those versions.

 

 

 

Edit..

 

 

 

Also I had both versions running on the same box prior to the install of TCA so it is not a conflict with mixing versions.

Link to comment
Share on other sites

OK I resolved it.

 

 

 

 

 

Solution:

 

 

 

Make a retail install.rar file and let TCA do the install.

 

Set the service for manual execution with my command line /serveonly switch and to interact with Desktop

 

 

 

Go into services and start it.

 

 

 

Then handle it interactively from the desktop.

 

 

 

Kind of a PIA but seems to be the only way to get something to run once TCA is installed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 5 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use