Jump to content

Valheim (V+ support and custom scripts)


Dennis
 Share

Recommended Posts

Valheim (V+ support and custom scripts)


Installation

  1. Download the config
  2. Go to TCAdmin > System > Settings > Game & Voice Hosting > Game & Other Voice Servers > Import
  3. Save the config as a new config or chose "Overwrite existing config" if you which to overwrite your current Valheim config. Remember to select Valheim in the 'Update Game' field if you do
  4. Leave all other settings

Features

  • Valheim Plus (V+) support - V+ will also update during Steam Updates
  • Wipe server
  • Easy management of banned players, permitted players and admins
  • Customizable commandline
  • TCAdmin will automatically generate server password

 

Link to comment
Share on other sites

12 hours ago, nubprah said:

Hi,

Is custom command line supposed to look like this?

commandline.thumb.png.43a0ec28c1bdbc29e8bf0abf52266c62.png

Thanks

Looks the same as mine. However, it would be nice with two aditional options here, servername and password (maybe it's a bug?). A small detail for some perhaps, but if one is to setup a server manually and forgets to change the default server name and the random created password when creating the server, then you will be kinda lost (at least i was). In the start_headless_server.bat where one should think that you could edit servername and password, it is unchanged and different compared to the commandline in the control panel. And to be honest, i can't find another file or folder with the servername or password attached to it so i can change them.

Link to comment
Share on other sites

19 hours ago, Sukkerpups said:

Looks the same as mine. However, it would be nice with two aditional options here, servername and password (maybe it's a bug?). A small detail for some perhaps, but if one is to setup a server manually and forgets to change the default server name and the random created password when creating the server, then you will be kinda lost (at least i was). In the start_headless_server.bat where one should think that you could edit servername and password, it is unchanged and different compared to the commandline in the control panel. And to be honest, i can't find another file or folder with the servername or password attached to it so i can change them.

 

Link to comment
Share on other sites

@Smolf and @Sukkerpups, there's currently an issue where TCAdmin doesn't export configurations made for predefined variables (like PrivatePassword and Hostname). It's fixed in 2.0.161.0, but this version is not released yet. Update should be available later today/tomorrow.

Until then, you can go to the game config > Variables > Default variables and allow access to Hostname and PrivatePassword variables.

Once TCAdmin 2.0.161.0 is released, I'll have to re-upload my current config.

Link to comment
Share on other sites

@Smolf Just updating TCAdmin won't fix the issue. The problem is that TCAdmin doesn't export the default variable configuration when I export the config - so no matter how many times you'd try to reinstall the first version of the config, it wouldn't work. The configuration wouldn't be in that version of the configuration file.

I've exported the config and uploaded it to the forums again as version 1.0.1. Nothing else is changed.

Link to comment
Share on other sites

14 minutes ago, Dennis said:

@Smolf Just updating TCAdmin won't fix the issue. The problem is that TCAdmin doesn't export the default variable configuration when I export the config - so no matter how many times you'd try to reinstall the first version of the config, it wouldn't work. The configuration wouldn't be in that version of the configuration file.

I've exported the config and uploaded it to the forums again as version 1.0.1. Nothing else is changed.

Still the same, only world i can change from commandline.

Link to comment
Share on other sites

5 hours ago, Dennis said:

I've reported it to Luis. There's nothing I can do before it's fixed.

You should just configure the default variables to be user accessible.

I tried that many times, but cant..

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Who's Online   0 Members, 0 Anonymous, 2 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use