Jump to content

Craftopia


Recommended Posts

Craftopia


Installation:

  1. Download the config
  2. Go to TCAdmin > System > Settings > Game & Voice Hosting > Game & Other Voice Servers > Import
  3. Save the config as a new config or chose "Overwrite existing config" if you which to overwrite your current CRAFTOPIA config. Remember to select CRAFTOPIA in the 'Update Game' field if you do
  4. Leave all other settings

Included:

  1. Configuration Editor.
  2. Console.

Issues:

  1. Player number max 7 at present.
  2. Still in devolpement.
  3. No query protocol. At present set to conole wrapper.

If anything needs changing let us know.


 

Edited by jungleNZ
spelling
Link to comment
Share on other sites

Posted (edited)
5 hours ago, conceptr980 said:

Hello ..

I dont see the configuration editor since there is no config file though more than just variables

Could you confirm ... Thx

Strange mine shows:

(I have re uploaded the config file in case something on it was not right)

config.jpg

Edited by jungleNZ
Link to comment
Share on other sites

I believe i got something .. it gives the following error once i try to import the config:

 

Unknown column 'docker_parameter' in 'field list'

 

Does docker has to be installed in windows server ?? because i dont have it installed as i think its not required for tcadmin

Thx

Screenshot 2022-04-26 at 04-03-01 POT Gaming - Games & Other Voice Servers.png

Link to comment
Share on other sites

I believe your config has nothing wrong more than its another issue. I tried to install it from the plugin repo instead of uploading it manually and the issue still the same.

On the other hand, i tried to remove docker parameter from the config it self but its seems its not removable.

 

Maybe @Dennis or @LFA might be handy in this case. Thx

Screenshot 2022-04-26 at 12-34-51 POT Gaming - Plugin Details.png

Link to comment
Share on other sites

After looking at the config a big i found this command:

<docker_parameter>0</docker_parameter>

 

I tried to remove it then save but it comes back by it self again for some reason. Then, i compared that line to the other game configs and it seems its not there which is only with yours. Are you able to investigate more or maybe to upload a config without that line.

 

Thx

Link to comment
Share on other sites

6 hours ago, conceptr980 said:

After looking at the config a big i found this command:

<docker_parameter>0</docker_parameter>

 

I tried to remove it then save but it comes back by it self again for some reason. Then, i compared that line to the other game configs and it seems its not there which is only with yours. Are you able to investigate more or maybe to upload a config without that line.

 

Thx

Will look at it but not sure what it is. Have not seen the word docker anywhere when setting up.

Have removed all variables. Try this config and see if same thing happening.

 

craftopia - Windows(1).xml

Link to comment
Share on other sites

34 minutes ago, jungleNZ said:

Will look at it but not sure what it is. Have not seen the word docker anywhere when setting up.

Have removed all variables. Try this config and see if same thing happening.

 

craftopia - Windows(1).xml 34.69 kB · 0 downloads

This one imported successfully ... That means its related to one or more variable since you removed them.

 

As for the original config were you mentioned there is no docker. If you edit the config manually, you will see the following:

<docker_parameter>0</docker_parameter>

Image Attached

 

Thx

docker.jpg

Edited by conceptr980
Link to comment
Share on other sites

On 4/26/2022 at 11:37 AM, conceptr980 said:

I believe your config has nothing wrong more than its another issue. I tried to install it from the plugin repo instead of uploading it manually and the issue still the same.

On the other hand, i tried to remove docker parameter from the config it self but its seems its not removable.

 

Maybe @Dennis or @LFA might be handy in this case. Thx

Screenshot 2022-04-26 at 12-34-51 POT Gaming - Plugin Details.png

This happens because the config was exported using a newer version of TCAdmin than you're using to import it.

You can open the .xml file and remove the lines from the file. You will not be able to install it from the plugin repository, however. You will need to upload the config manually.

Link to comment
Share on other sites

15 hours ago, Dennis said:

This happens because the config was exported using a newer version of TCAdmin than you're using to import it.

You can open the .xml file and remove the lines from the file. You will not be able to install it from the plugin repository, however. You will need to upload the config manually.

Thank you for your reply ..

 

Im using TCadmin 2.0.177.0 with MySql but maybe database tables are outdated due to many updates .. any idea how to fix it ? or how to recheck database tables and upgrade them to the latest version.

Side Note: The lines cant be removed as i tried already

Thx

Link to comment
Share on other sites

Posted (edited)
5 minutes ago, Dennis said:

Try upgrading to 2.0.177.6: https://help.tcadmin.com/Updating#Manual_Update

Also, the lines can be removed. Save the file to your desktop and make sure it's not saved as read only. It's a simple XML file. TCAdmin won't prevent anything from changing it.

about editing files .. yeah im aware its simple xml but you can try your self and see if it could be removed, once i remove and save it reverts back by it self.

 

Update: (the read only part) that part maybe i missed it

 

as for the upgrade .. ill give it a shot and hopefully it will fix the issue.

 

Thx

Edited by conceptr980
Link to comment
Share on other sites

Posted (edited)
11 minutes ago, Dennis said:

Try upgrading to 2.0.177.6: https://help.tcadmin.com/Updating#Manual_Update

Also, the lines can be removed. Save the file to your desktop and make sure it's not saved as read only. It's a simple XML file. TCAdmin won't prevent anything from changing it.

Updated to 2.0.177.6

result still the same

 

update: i checked file is not read only and not blocked then removed the line and saved, it reverts back by it self

 

Screenshot 2022-05-02 at 14-57-16 POT Gaming - Games & Other Voice Servers.png

Edited by conceptr980
Link to comment
Share on other sites

Posted (edited)
18 minutes ago, Dennis said:

As I said previously, the file can be edited just fine. See this: https://streamable.com/5ljqks

If you can't change it, it's because you saved the file as read only.

upload that XML since it saved with you 😆

 

Even though i prefer to fix the issue from the root by using latest TCAdmin standards instead but as you can see, even latest version is not doing the trick (at least in my case)

Edited by conceptr980
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Who's Online   0 Members, 0 Anonymous, 23 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use