Jump to content

Command Line Help


Recommended Posts

Hello all,


I offer 33, 66 and 100 tickrate servers. Obviously I dont want a customer whos paying for a 33 tickrate to have a 100 tickrate server. Is there anyway to set the commandline so only I can create a command line with the tickrate edittable.


I could setup multiple versions of the sam game but that could take some time.

Link to comment
Share on other sites

If an admin wants to add the tickrate command to a server's command line they can simply input the value in the "additional arguments" field in service details.




Also as you mentioned above you could also setup multiple game types for the different tickrates. You can simply copy the same config and re-name it so you don't need to create it again.




Something like Counterstrike 33 Tic, Counterstrike 66 Tic etc..




Easiest way would be to simply create the CS game and add the ticrate or tickrate command to the additional arguments field for that particular game. Restart the game server and you are good to go.




Remember to open Windows Media Player on your server desktop and leave it running to set the multimedia timer on your system or the tickrates will not work in-game.




Check this video out to see how it is done:



Link to comment
Share on other sites

Damm, learn something new every day. Wonder how many server providers do actually open WMP.


Will having WMP to mae the tickrate work effect the cpu usage.




I.e. Without WMP will the server use 33 tickrate cpu, even if you use the -tickrate command?

Link to comment
Share on other sites

The media player take a tiny amount of RAM when open of course, but no CPU. What will take CPU is the game itself. Bumping the tickrate up will cauase the game to use more CPU than a normal game. So be careful when using it and pricing your games. Most hosts charge more for boosted servers for these reason. If you don't leave media player open, then putting the tic in the command line won't do anything unless you use a boosting module.

Link to comment
Share on other sites

  • 4 weeks later...

If it helps, here is the custom command line;




-game cstrike -console +ip %serverip% -port %serverport% +maxplayers %slots% %usercmdline%






I am trying to input -tickrate 100 in the additional arguments box to no avail except on the default line, which is:




-game cstrike -console +ip %serverip% -port %serverport% +maxplayers %slots% +exec server.cfg +map de_aztec

Link to comment
Share on other sites

I will test this and report back Bob. Just to clarify. You are going into service settings and entering the -tickrate into the additional arguments, then saving and restarting the game?




And the tickrate is not showing 100 in the game console?



Link to comment
Share on other sites

I fixed your problem and will be available in the next update.




The problem was that the additional arguments set in the service settings was not being placed in custom command lines. it was set only the default.




I also added a command line variable named %additionalarguments% so you can decide where to put the additional parameters. Some games like UT 2004 like the command arguments in a certain order or else they won't accept the values. With that variable you can decide where to place it.




If your command lines don't contain %additionalarguments% is will just place it at the end like it currently does.

Link to comment
Share on other sites

  • 3 months later...

Apologies for dragging this thread up but I have a client server which I had to reinstall today using tcadmin




the command line is this




-game cstrike -tickrate 66 -console +ip xx.xxx.xxx.xxx -port 27015 +maxplayers 20 +exec server.cfg +map de_aztec




But the tickrate is showing as 33




before install it was fine




I also manually installed mani admin with it (did that the first time with np also)




Any ideas where or why its being changed to 33

Link to comment
Share on other sites

Most likely because your command line is not set properly.




If you login to the panel and click on that game service and then on "Service Properties" you will see a "Preview" button. Click the button and it will show you the current commandline for that game server.




Here is the commandline I setup as a test:


E:\ClientFiles\ADMIN\GameServers\TCXXXXXXXXXXXXXXXXXXXXXXXXX XXXX\srcds.exe -game cstrike -console +ip xx.xx.xx.xx -port 27015 +maxplayers 5 +exec server.cfg +map de_aztec -tickrate 100




And here is the response I get from rcon when asking for the tickrate:






"mani_tickrate" = "100" ( def. "" )


notify replicated


- Server tickrate information




Now go into your game config for CSS and check what you have setup for a default commandline, and compare the two.






This thread addressed a problem with additonal variables not being added to the commandline after being set within the service settings after the server was allready installed and running.





Link to comment
Share on other sites

Hey everyone...hope I can clear this up...




Half-life 1 mods: you can add the following to the command line




+sys_ticrate xxx +fps_max xxx




example: +sys_ticrate 600 +fps_max 600 (floats the server at 550 fps -- which is our highest boosting package)




Half-life 2 mods:




-tickrate xxx




example - tickrate 100




I really don't advise boosting the fps in the command line for css. With WMP open, the Source FPS defaults to 250, more than enough for all players to get awesome registry that they pay for.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use