Jump to content

TCAdmin 2.0.145 now available (stable)


LFA
 Share

Recommended Posts

New

  • Added support for processor groups (more than 64 cores).
  • Reduced control panel CPU usage.
  • Improved control panel performance specially when viewing services on remote servers.
  • Optimized WHMCS sync task.
  • Optimized billing api server selection.
  • Updated IronPython to 2.7.9. Scripts don't require Python 2.7 anymore.
  • Sub admins are not allowed to create custom FTP virtual directory outside of the user files path.
  • Fast download sync can only be started once per service.
  • Game keys can be configured per IP.
  • Added before workshop auto update event. An example for this event that sends a message to players can be found here.
  • Added before steam auto update event.
  • Added subadmin permission to override min slots.
  • Added sub admin role permissions for edit/view servers, edit/view server IPs. Previously the server permission gave full access to these settings.
  • All text in the Workshop browser can be translated except the text from Steam.
  • Added option to update existing theme in MVC theme import.
  • Added start time and fast download info to MVC. Date will be correct after next restart. Updated 2020 templates can be downloaded here.
  • Added start time to ASPX (temporarily removed in 2.0.144 beta). Date will be correct after next restart.
  • Added fast download live stat to ASPX templates.

Plugins/Modules

Bugs

  • Fixed error when stopping the monitor and killing sub processes.
  • Fixed game server mover when master is running on Linux.
Link to comment
Share on other sites

I have updated. Running assetto corsa servers with made config. Executable goes through folder ac and runs acServer.bat.

The servers do NOT now start. ANy ideas? No logs to show any error. I have tried to start be replacing .bat with .exe. Still no go.

I have solved it by changing run as from tcadmin game to local user. Not the best solution.

Edited by jungleNZ
Link to comment
Share on other sites

11 hours ago, Jimmy-CS said:

But the Join button was removed ?

Sorry install the update again to get it back.

 

19 hours ago, impactor said:

I have this problem on 2.0.145.0  Unknown column 'tc_services.numa_node' in 'field list'

Make sure you install the update using system > check updates. If you install the update manually it does not update the database.

 

21 hours ago, jungleNZ said:

Thanks, will read through compatible (my servers run server2016). All was fine until last update.

Have you tried downgrading back to 2.0.143 to test if it starts? The way the services are started has not changed. The only change is after they have been started it changes the processor group but that is only applied if you have more than 64 cores.

Maybe you can also try with TCAdmin.EnableLauncherService=False in TCAdminServiceManager.exe.config. You will have to kill all TCAdminServiceLauncher.exe processes and restart the service manager.

Link to comment
Share on other sites

16 hours ago, DennisHermannsen said:

@Jimmy-CS the join button is still included in the default design. Are you sure it's been setup correctly in your TCAdmin installation?

Luis fixed it.. all good now ?

 

12 hours ago, impactor said:

I try from panel and manual,same problem... 

can i update mysql manual maybe?
or i need reinstall server ?

You probably broke it if you're trying to do it manually. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use