Jump to content

Swat 4


JasonF

Recommended Posts

I have it automated with the command line but can't get the query port automation. I have searched for the setting in the UT engine but can not locate it. Does anyone know the setting in the UT ini to adjust the query port?

Link to comment
Share on other sites

Well I have it automated to create a SWAT 4 server but for the life of me can't figure out how to get this engine from binding to the same query port. I pulled out a UT and Raven Shield ini to see what variables it uses with no luck. When I try to create a second server it will bind to the same query port so I could only get 1 server to run per box. I checked it out via Qtracker and was not able to check in game to see if the server showed up. The server log showed a query port of 10481 for all SWAT 4 servers I created.

 

Also, maxplayers will not respond in the command line but the server port will so I don't think you would be able to restrict the player count for a client. This is what I have so far, I have tested it and it works.

swat.txt

Link to comment
Share on other sites

  • 2 years later...

Swat 4 ports

Outgoing UDP and TCP traffic must be able to run without restriction. The entire UDP traffic (incoming and outgoing) must be on the ports 10480, 10481, 10482, 10483,10486, 10490, 10491 and 10495 passed through (forwarded) on the host.

 

also make sure you have the following set in your server.ini

 

[ipDrv.UdpBeacon]

DoBeacon=True

 

[ipDrv.MasterServerUplink]

DoUplink=True

Link to comment
Share on other sites

Does anything need to be below this:

 

[ipDrv.MasterServerUplink]

DoUplink=True

 

Also we have all ports open... they are also saying they install web admin and works fine but cant even connect to the game server even though it shows up fine in hlsw.

 

Edit: I look at console and says unable to query game spy incoming port blah blah but all ports are open...

Edited by Derek
Link to comment
Share on other sites

last time i looked

just edit the port numbers to go with your servers

 

[ipDrv.UdpGamespyQuery]

QueryPortNumber=10581

 

[ipDrv.UdpBeacon]

DoBeacon=True

BeaconTime=0.50

BeaconTimeout=5.0

BeaconProduct=swat4

ServerBeaconPort=10587

BeaconPort=10588

DoUplink=True

 

[ipDrv.MasterServerUplink]

DoUplink=True

Edited by louise
Link to comment
Share on other sites

last time i looked

just edit the port numbers to go with your servers

 

[ipDrv.UdpGamespyQuery]

QueryPortNumber=10581

 

[ipDrv.UdpBeacon]

DoBeacon=True

BeaconTime=0.50

BeaconTimeout=5.0

BeaconProduct=swat4

ServerBeaconPort=10587

BeaconPort=10588

DoUplink=True

 

[ipDrv.MasterServerUplink]

DoUplink=True

 

heh still not working. what the heck... it shows up on hlsw but server administration doesnt turn any results..

Link to comment
Share on other sites

  • 3 years later...
Log: ****************************************************

Log: Beginning level load: 'Entry.s4m'

Log: ****************************************************

Log: ****************************************************

Log: Finished level load in 0.005 seconds

Log: ****************************************************

Log: Building Collision Octree...

Log: Finished Building Collision Octree

Log: Game class is 'GameInfo'

Log: Bound to IpDrv.dll

Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467

Init: WinSock: Socket queue 131072 / 131072

Init: WinSock: I am ks4003148 (142.4.206.187)

DevNet: TcpNetDriver on port 10480

Log: Server Package: Core

Log: Server Package: Engine

Log: Server Package: IGEffectsSystem

Log: Server Package: IGVisualEffectsSubsystem

Log: Server Package: IGSoundEffectsSubsystem

Log: Server Package: Editor

Log: Server Package: UWindow

Log: (server-side only)

Log: Server Package: GamePlay

Log: Server Package: GUI

Log: Server Package: SwatEd

Log: Server Package: IpDrv

Log: (server-side only)

Log: Server Package: Tyrion

Log: Server Package: AICommon

Log: Server Package: Scripting

Log: Server Package: SwatAIAwareness

Log: Server Package: SwatAICommon

Log: Server Package: RWOSupport

Log: Server Package: SwatGame

Log: Server Package: SwatEffects

Log: Server Package: SwatEquipment

Log: Server Package: SwatProtectiveEquipment

Log: Server Package: SwatSimpleEquipment

Log: Server Package: SwatObjectives

Log: Server Package: SwatProcedures

Log: Server Package: SwatGui

Log: Bound to SwatGui.dll

Log: Server Package: SwatEquipmentModels

Log: Server Package: SWATofficerTex

Log: Server Package: mp_OfficerTex

Log: Server Package: SwatAmmo

Log: Server Package: SwatCameraEffects

Log: Server Package: SW_Objects

Log: Server Package: SW_Bounce

Log: Server Package: SW_Ambients

Log: Server Package: SW_Bullets

Log: Server Package: SW_Feet

Log: Server Package: SW_Hits

Log: Server Package: SW_Meta

Log: Server Package: SW_VO

Log: Server Package: SW_Weapons

Log: Server Package: SWATMaleAnimation

Log: Server Package: FemaleAnimation

Log: Server Package: SwatBadguyTex

Log: Server Package: FemaleCasual1Tex

Log: Server Package: FemaleCasual2Tex

Log: Server Package: FemaleCasual3Tex

Log: Server Package: FemaleHeavyTex

Log: Server Package: FemaleNurseTex

Log: Server Package: FemaleOfficeTex

Log: Server Package: CultLeaderTextureSet

Log: Server Package: LeoMelTextureSet

Log: Server Package: MaleCasual1Tex

Log: Server Package: MaleCasual2Tex

Log: Server Package: MaleCasual3Tex

Log: Server Package: MaleCasual4Tex

Log: Server Package: MaleCasualArmorTex

Log: Server Package: MaleChubbyTex

Log: Server Package: MaleDoctorTex

Log: Server Package: MaleGang1Tex

Log: Server Package: MaleJanitorTextureSet

Log: Server Package: MaleSuitTex

Log: Spawning: IpDrv.MasterServerUplink

Log: UGameSpyManager::InitAsServer().

Log: Level is Level Entry.myLevel

Log: *** WARNING - PATHS MAY NOT BE VALID ***

Log: Bringing Level Entry.myLevel up for play (20)...

Log: ---------- IsTheEntryLevel = 1, GameEngine=0x2D52000, GameEngine->GEntry=0x0, GameEngine->GEntry->GetLevelInfo()=0x0, current LevelInfo=0x99EC400

Log: MasterServerUplink::Reconnect().

Log: ...Engine URL Port=0

Log: Resolving ut2003master1.epicgames.com...

Log: Loadmap executed in 0.13 seconds. (0.00 Verify) (0.01 Load) (0.12 Actor Init)

Log: URL: Adding default option Class=SwatGame.SwatPlayer

Log: URL: Adding default option team=255

Log: Browse: MP-Training?Name=Player?dedicated?Class=SwatGame.SwatPlayer?team=255

Log: LoadMap: MP-Training?Name=Player?dedicated?Class=SwatGame.SwatPlayer?team=255

Warning: Failed to load 'pier_tex': Can't find file for package 'pier_tex'

Warning: Failed to load 'pier_tex': Can't find file for package 'pier_tex'

Warning: Missing Texture Texture pier_tex.shiphull

Log: [dkaplan]: URL.Map = MP-Training

Exit: Socket shut down

 

help me please what is the problem?

 

 

sorry for my bad english

Link to comment
Share on other sites

sorry now is my console:

Log: Log file open, 08/18/13 17:10:37

Init: ----------------------------------------

Init: SWAT VERSION NUMBER: 31973

Init: ----------------------------------------

Init: Compiled: Feb 18 2005 18:08:30

Init: Command line: -server -ini=Swat4DedicatedServer.ini -port=10480 -server

Init: Base directory: D:\TCAFiles\Users\buddyqc\58\Content\System\

Init: Character set: Unicode

Init: Found startup configuration: Startup.ini

Init: Adding FilePath: ..\..\Content\System;..\..\Content\Scenarios;..\..\Content\Maps;..\..\Content\Test\Maps

Log: Bound to Window.dll

Log: Bound to Core.dll

Log: Bound to Scripting.dll

Log: Bound to Engine.dll

Log: Bound to SwatAIAwareness.dll

Log: Bound to AICommon.dll

Log: Bound to ALAudio.dll

Init: Object subsystem initialized

Init: Computer: KS4003148

Init: User: TCAGame

Init: CPU Page size=4096, Processors=4

Init: CPU Detected: PentiumPro-class processor (GenuineIntel)

Init: CPU Features: CMov FPU RDTSC PAE MMX SSE

Init: CPU Speed=3392.458550 MHz

Init: Memory total: Phys=4194303K Pagef=4194303K Virt=2097024K

Init: Working set: 32000 / 159000

Log: Bound to SwatGame.dll

Log: Bound to RWOSupport.dll

Log: Bound to Tyrion.dll

Log: Bound to GUI.dll

Log: Bound to SwatAICommon.dll

Log: Bound to Editor.dll

Log: Bound to ScriptCompiler.dll

Log: Bound to IGEffectsSystem.dll

Log: Bound to IGSoundEffectsSubsystem.dll

Log: (Havok): Initializing base system.

Log: Bound to IGVisualEffectsSubsystem.dll

Init: Unreal engine initialized

Log: Updating Revision level for 2C2FD8CB47D62DE10B39E182297C0502 to 0

Log: Updating Revision level for 6D47E4E64D3E9E8AC53D36AF3FCDE640 to 0

Log: Updating Revision level for B2F0D1D146DE61D41E2E90B1F12153B6 to 0

Log: Updating Revision level for 9AE9B84F436374391D24DAAC21EAFD2D to 0

Log: Updating Revision level for F75542994507C56C25C229970561678B to 0

Log: Updating Revision level for 834928B943BF5E7499C6A9ACDBBACA1E to 0

Log: Updating Revision level for C9A5CB6D446B2D54A159799765FED41B to 0

Log: Updating Revision level for 71CB225A455001431F6B45AD83FA9B01 to 0

Log: Updating Revision level for 75682A7E47E714D1F14D0C95616FFD33 to 0

Log: Updating Revision level for 33AF74004BF3642B07E0B38A653FC2F3 to 0

Log: Updating Revision level for 5DA17DAD424C4A37F0658897F5EE1A26 to 0

Log: Updating Revision level for CAA517B642AA5EB562DF00B195CADE38 to 0

Log: Updating Revision level for F1D9791E4B3A5669FD7BEDAE164BAF99 to 0

Log: Updating Revision level for C4D49E82435E3DE6802695B5634EEF6D to 0

Log: Updating Revision level for BF95712944E58D69A78BFB892F1CA491 to 0

Log: Updating Revision level for F58AC3D94F8E43B575C07F9ECD86DE3A to 0

Log: Updating Revision level for 9EB460054185F017761C0E8699640EC3 to 0

Log: Updating Revision level for AB8E847141AEE8FCEF438997B16D065E to 0

Log: Updating Revision level for 948518D141E395A6D08CADAD9B9B0E8F to 0

Log: Updating Revision level for 95B52CB3450118346E2C55A62EE09FB1 to 0

Log: Updating Revision level for CE4CCC114F4988FAE974969284A89372 to 0

Log: Updating Revision level for 6E5FBA5D48D3A0A3009AAD9DBB8B0D5D to 0

Log: Initializing the game as a dedicated server!

Log: UGameEngine::Init() ... CommandLine = -server -ini=Swat4DedicatedServer.ini -port=10480 -server

Log: Browse: Entry.s4m?Name=Juouer?Class=SwatGame.SwatPlayer?team=255

Log: LoadMap: Entry.s4m?Name=Juouer?Class=SwatGame.SwatPlayer?team=255

Log: [dkaplan]: URL.Map = Entry.s4m

Log: ****************************************************

Log: Beginning level load: 'Entry.s4m'

Log: ****************************************************

Log: ****************************************************

Log: Finished level load in 0.005 seconds

Log: ****************************************************

Log: Building Collision Octree...

Log: Finished Building Collision Octree

Log: Game class is 'GameInfo'

Log: Bound to IpDrv.dll

Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467

Init: WinSock: Socket queue 131072 / 131072

Init: WinSock: I am ks4003148 (142.4.206.187)

DevNet: TcpNetDriver on port 10480

Log: Server Package: Core

Log: S

Link to comment
Share on other sites

  • Who's Online   0 Members, 0 Anonymous, 29 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use